summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorEnrico Jorns <ejo@pengutronix.de>2021-08-20 02:06:23 +0200
committerEnrico Jorns <ejo@pengutronix.de>2021-08-23 13:43:32 +0200
commitcd0fc16476c87a50c84685f9170fbd4762540f31 (patch)
tree30288ec336e045d6ff9c29d05df89fced1153dc8 /recipes-core
parent5a4bceee4a32e55d61bc4a1e1cd36c3d14340497 (diff)
downloadmeta-ptx-cd0fc16476c87a50c84685f9170fbd4762540f31.tar.gz
meta-ptx-cd0fc16476c87a50c84685f9170fbd4762540f31.tar.xz
update to honister's new override style syntax
Done with conversion script: scripts/contrib/convert-overrides.py meta-ptx Update layer compatibility to honister. Note: New override-style syntax is supported by latest version of poky hardknott. Thus compatiblitiy should actually be given. Signed-off-by: Enrico Jorns <ejo@pengutronix.de>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/busybox/busybox_%.bbappend2
-rw-r--r--recipes-core/dt-utils/dt-utils.inc14
-rw-r--r--recipes-core/ptx-profile/ptx-profile.bb2
-rw-r--r--recipes-core/systemd/systemd-rc-once.bb6
4 files changed, 12 insertions, 12 deletions
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
index 0119b51..2682035 100644
--- a/recipes-core/busybox/busybox_%.bbappend
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://resize.cfg"
diff --git a/recipes-core/dt-utils/dt-utils.inc b/recipes-core/dt-utils/dt-utils.inc
index f07c625..0366c99 100644
--- a/recipes-core/dt-utils/dt-utils.inc
+++ b/recipes-core/dt-utils/dt-utils.inc
@@ -13,10 +13,10 @@ inherit autotools pkgconfig gettext
PACKAGES =+ "${PN}-barebox-state ${PN}-barebox-state-dbg ${PN}-fdtdump ${PN}-fdtdump-dbg ${PN}-dtblint ${PN}-dtblint-dbg"
NOAUTOPACKAGEDEBUG = "1"
-FILES_${PN}-barebox-state = "${bindir}/barebox-state"
-FILES_${PN}-barebox-state-dbg = "${bindir}/.debug/barebox-state"
-FILES_${PN}-fdtdump = "${bindir}/fdtdump"
-FILES_${PN}-fdtdump-dbg = "${bindir}/.debug/fdtdump"
-FILES_${PN}-dtblint = "${bindir}/dtblint"
-FILES_${PN}-dtblint-dbg = "${bindir}/.debug/dtblint"
-FILES_${PN}-dbg = "${libdir}/.debug/"
+FILES:${PN}-barebox-state = "${bindir}/barebox-state"
+FILES:${PN}-barebox-state-dbg = "${bindir}/.debug/barebox-state"
+FILES:${PN}-fdtdump = "${bindir}/fdtdump"
+FILES:${PN}-fdtdump-dbg = "${bindir}/.debug/fdtdump"
+FILES:${PN}-dtblint = "${bindir}/dtblint"
+FILES:${PN}-dtblint-dbg = "${bindir}/.debug/dtblint"
+FILES:${PN}-dbg = "${libdir}/.debug/"
diff --git a/recipes-core/ptx-profile/ptx-profile.bb b/recipes-core/ptx-profile/ptx-profile.bb
index 685913f..53ea1a2 100644
--- a/recipes-core/ptx-profile/ptx-profile.bb
+++ b/recipes-core/ptx-profile/ptx-profile.bb
@@ -11,4 +11,4 @@ do_install () {
install -m 0755 ${S}/00-ptx.sh ${D}${sysconfdir}/profile.d/
}
-FILES_${PN} = "${sysconfdir}/profile.d/00-ptx.sh"
+FILES:${PN} = "${sysconfdir}/profile.d/00-ptx.sh"
diff --git a/recipes-core/systemd/systemd-rc-once.bb b/recipes-core/systemd/systemd-rc-once.bb
index 6c7055b..804f378 100644
--- a/recipes-core/systemd/systemd-rc-once.bb
+++ b/recipes-core/systemd/systemd-rc-once.bb
@@ -24,14 +24,14 @@ do_install() {
install -d ${D}${sysconfdir}/rc.once.d
}
-FILES_${PN} += "\
+FILES:${PN} += "\
/lib/init/rc-once.sh \
/lib/systemd/systemd-rc-once \
/lib/systemd/system/system-update.target.wants/rc-once.service \
"
-SYSTEMD_SERVICE_${PN} = "rc-once.service"
+SYSTEMD_SERVICE:${PN} = "rc-once.service"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
ln -sf etc/rc.once.d $D/system-update
}