summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorEnrico Jorns <ejo@pengutronix.de>2015-06-26 16:12:44 +0200
committerEnrico Jorns <ejo@pengutronix.de>2016-01-22 09:31:42 +0100
commitf3263b42bcb4150d7cb97400ad73a846b0f54bb1 (patch)
treeec6d58e71280b845114875b68d27b77fc791dab8 /recipes-core
parent89ccc18f6b847b04310dd06f76a54cdad3c09f6c (diff)
downloadmeta-ptx-f3263b42bcb4150d7cb97400ad73a846b0f54bb1.tar.gz
meta-ptx-f3263b42bcb4150d7cb97400ad73a846b0f54bb1.tar.xz
Create ptx-profile recipe and add to core-boot
ptx-profile provides a profile.d config with some default aliases for ptx users Signed-off-by: Enrico Jorns <ejo@pengutronix.de>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/packagegroups/packagegroup-core-boot.bbappend1
-rw-r--r--recipes-core/ptx-profile/ptx-profile.bb14
-rw-r--r--recipes-core/ptx-profile/ptx-profile/ptx-profile13
3 files changed, 28 insertions, 0 deletions
diff --git a/recipes-core/packagegroups/packagegroup-core-boot.bbappend b/recipes-core/packagegroups/packagegroup-core-boot.bbappend
new file mode 100644
index 0000000..55a3e73
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-core-boot.bbappend
@@ -0,0 +1 @@
+RDEPENDS_${PN} += "ptx-profile"
diff --git a/recipes-core/ptx-profile/ptx-profile.bb b/recipes-core/ptx-profile/ptx-profile.bb
new file mode 100644
index 0000000..03d78a3
--- /dev/null
+++ b/recipes-core/ptx-profile/ptx-profile.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "PTX distro specific profile"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://ptx-profile"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${S}/ptx-profile ${D}${sysconfdir}/profile.d/
+}
+
+FILES_${PN} = "${sysconfdir}/profile.d/ptx-profile"
diff --git a/recipes-core/ptx-profile/ptx-profile/ptx-profile b/recipes-core/ptx-profile/ptx-profile/ptx-profile
new file mode 100644
index 0000000..ba3dfb9
--- /dev/null
+++ b/recipes-core/ptx-profile/ptx-profile/ptx-profile
@@ -0,0 +1,13 @@
+# /etc/profile.environment - config for sub-shells
+PS1="\\u@\\h:\\w "
+PS2=" >"
+PS4="+ "
+
+alias vim='vi'
+alias l='ls -l'
+alias ll='ls -al'
+alias ..='cd ..'
+alias ...='cd ../..'
+alias md='mkdir'
+alias rd='rmdir'
+