summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJuergen Beisert <j.beisert@pengutronix.de>2009-04-24 09:33:24 +0000
committerJuergen Beisert <j.beisert@pengutronix.de>2009-04-24 09:33:24 +0000
commit850a0ba2cc68e9b70ffa3cc968c08efd67de2dcd (patch)
tree1cee85f55203f82a085d5503645da7be0b8ac114 /configure.ac
parent00a59ebaedd229d17425ba1da7216cdf7a94315e (diff)
downloadfloatings-850a0ba2cc68e9b70ffa3cc968c08efd67de2dcd.tar.gz
floatings-850a0ba2cc68e9b70ffa3cc968c08efd67de2dcd.tar.xz
adding a softfloat only variant to check our toolchainsHEADmaster
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8751b5..36594f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([floatings], [1.1.0], [bugs@pengutronix.de])
+AC_INIT([floatings], [1.1.1], [bugs@pengutronix.de])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([src/float_bench.c])
AC_CANONICAL_BUILD
@@ -35,6 +35,26 @@ AC_CHECK_HEADERS([ \
AC_FUNC_MALLOC
AC_CHECK_FUNCS([memset sqrt gettimeofday])
+#
+# Try to detect the architecture we should compile for
+#
+case $host_cpu in
+ i*86)
+ TARGET_X86=true
+ ;;
+ arm)
+ TARGET_ARM=true
+ ;;
+ powerpc)
+ TARGET_PPC=true
+ ;;
+ *)
+ ;;
+esac
+
+AM_CONDITIONAL([TARGET_X86], [test x$TARGET_X86 = xtrue])
+AM_CONDITIONAL([TARGET_ARM], [test x$TARGET_ARM = xtrue])
+AM_CONDITIONAL([TARGET_PPC], [test x$TARGET_PPC = xtrue])
#
# Debugging