summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSascha Hauer <s.hauer@pengutronix.de>2013-09-19 11:39:25 +0200
committerSascha Hauer <s.hauer@pengutronix.de>2013-09-20 16:19:29 +0200
commitf9c23e3d7ccd2f4cbf958bb1e723485fea1eab9c (patch)
tree821f435f3b1614be5437f9ed428aec0140607f86 /Makefile.am
parent6706236161829dad6b7f6593648e39a3e96bd6ad (diff)
downloadkmsfbwrap-f9c23e3d7ccd2f4cbf958bb1e723485fea1eab9c.tar.gz
kmsfbwrap-f9c23e3d7ccd2f4cbf958bb1e723485fea1eab9c.tar.xz
Implement bgi
This uses cuse to implement a fake framebuffer in userspace suitable for the i.MX5 3d blob driver. To make this work: - disable legacy framebuffer in kernel (to be able for cuse to create /dev/fb0 - Apply Philipps 'PHYS' hack patch to be able to pass the physical address of the framebuffer to userspace On i.MX53 with TV encoder the following works: kmsfb-manage -s -f xres=640,yres=480,bpp=32,3d=1 -s -c crtc=8,fbid=%0,connector=4,encoder=3,xres=640,yres=480 -s -b 8 -v Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e09d77..76e01da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,8 @@ AM_CPPFLAGS = \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-I${top_srcdir}/src/kmsfbwrap \
-I${top_srcdir}/src \
- $(DRM_CFLAGS)
+ $(DRM_CFLAGS) \
+ $(FUSE_CFLAGS)
AM_CFLAGS = ${my_CFLAGS} \
-fvisibility=hidden \
@@ -53,7 +54,11 @@ src_libkmsfbwrap_la_DEPENDENCIES = ${top_srcdir}/src/libkmsfbwrap.sym
bin_PROGRAMS = kmsfb-manage
kmsfb_manage_SOURCES = \
- src/kmsfb-manage.c
+ src/kmsfb-manage.c \
+ src/bgi.c
+
+kmsfb_manage_LDADD = \
+ $(FUSE_LIBS)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = src/libkmsfbwrap.pc