summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..756e4f3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+bin_PROGRAMS = fpgaedit
+fpgaedit_SOURCES = fpgaedit.c fpgaedit_parser.c fpgaedit_parser.h \
+ y.tab.c y.tab.h lex.yy.c
+
+# only needed to recompile the commandlineparser
+fpgaedit_parser.c fpgaedit_parser.h: fpgaedit_parser.gp
+ genparse -o fpgaedit_parser fpgaedit_parser.gp
+
+y.tab.c y.tab.h: fpgaedit.y
+ $(YACC) -d $<
+
+lex.yy.c: fpgaedit.l
+ $(LEX) $<
+
+MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub \
+ configure depcomp install-sh ltmain.sh \
+ Makefile.in missing fpgaedit_parser.c \
+ fpgaedit_parser.h fpgaedit.tab.c fpgaedit.tab.h \
+ lex.yy.c
+
+EXTRA_DIST = bootstrap fpgaedit_parser.gp fpgaedit.l fpgaedit.y