summaryrefslogtreecommitdiffstats
path: root/web-gui/Makefile.am
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2010-06-04 12:44:35 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2010-06-04 12:58:39 +0200
commitc66e873ca11db0c81dac67c4715f81ada5ae435c (patch)
tree47ac2678fe30cc6f2d4ddc31a20808319a146a8d /web-gui/Makefile.am
parente4daa67ea3c8893aad6483c057ce1794a3be4374 (diff)
downloadjson-dbus-bridge-examples-c66e873ca11db0c81dac67c4715f81ada5ae435c.tar.gz
json-dbus-bridge-examples-c66e873ca11db0c81dac67c4715f81ada5ae435c.tar.xz
[web-gui] generate top-level index.html
Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'web-gui/Makefile.am')
-rw-r--r--web-gui/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/web-gui/Makefile.am b/web-gui/Makefile.am
index e0304e9..5cf8e07 100644
--- a/web-gui/Makefile.am
+++ b/web-gui/Makefile.am
@@ -3,9 +3,20 @@ SUBDIRS = \
hello-world \
calculator
+all: index.html
+
+index.html: index.sh
+ sh $< $(SUBDIRS) > $@
+
clean-local:
rm -rf qooxdoo-cache
+EXTRA_DIST = \
+ index.sh
+
+CLEANFILES = \
+ index.html
+
MAINTAINERCLEANFILES = \
Makefile.in